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Welcome to Easy Grade Pro, your electronic gradebook software. With timesaving tools and 
efficient reports, you’ll improve your ability to individualize instruction based on your classroom’s 
first-hand data. This course will first introduce basic skills in the pre-class assignment. In the 
classroom, we will discuss the finer points of setting up and running a sound gradebook. At the 
end of the course, you will understand and be able to explain how and why your grade book is 
set up. You will be able to make data-driven decisions at the touch of a key and produce 
meaningful reports for students and parents. 

Technology Standards 

 Tier 1 Teachers keep and organize student information / grades effectively. 
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A. Understanding the Design of Your Gradebook 

1. Grade Scales 

It is paramount that you set your grade scale 
appropriately. Most importantly, you should 
ensure that your gradebook does not give a 
grade that cannot be granted by Tacoma 
Public Schools. Complete the following. 

 Delete the A+ column* 
 Add a D+ column* 
 Change the F to an E 
 Adjust the scale to match your class 

procedures. 
*Use the blue menu arrow (circled) to insert/delete grades 

2. Categories 

To set up your categories, go Edit >Class 
Options and click on the Category Tab. In 
order to use category weights, choose “Yes” 
at the bottom of the window. You can now 
edit, add, or delete categories1. 

Elementary teachers should match the 
categories to the requirements of their 
eReport Grading system. 

Secondary teachers should match categories 
to their class procedures and/or department-established grading break-downs. 

3. Footnotes 

Footnotes allow you to add valuable 
information to a student’s grade. These 
Footnotes will come up on printed reports.  

To set up Footnotes, go Edit > Class 
Options and click on the Footnotes 
Tab.The text of Footnotes can be class-
specific. Consider the following: 

 What comments do you regularly 
make to students’ work? 

 How can you use this to track late work? 
 Put your most common Footnotes at the top. 

                                                 
1 While it is possible to add many categories, it is not recommended to have a large number. Categories with only a 
few grades can easily skew a student’s grade. 

Must add to 100 
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4. Special Scores 

This feature allows the teacher to add scores other than numerical grades. These scores can 
play an important organizational and communication structure for your gradebook. 

To set up Special Scores, go Edit > Class Options and click on the Score Tab. 

Items to consider when setting up and use Special Scores: 

 What value should the score get? Do absences count as zeros? 
 Blank Values receive no numerical value. It does not hurt the student, but it 

does not help them as well. 
 Remember the Shortcut key to save time when entering grades. 
 Utilize the missing assignments list to help students get caught up.  

 

 

Adds assignment 
to student’s 
missing list 

Keyboard Shortcut 

Value calculated 
by the gradebook 

Code that is placed in 
the gradebook and 
shows up on reports 
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5. Entering Assignments 

To add an assignment, press the Add Assignment button at the end of the assignments. 
From the following window, you can add or edit all assignments for this class. Enter the 
following information for each assignment. 

 Descriptive Name. You could include the GLE in parentheses if desired. 
 Set the Max Score. This is the maximum raw score for the assignment. 
 Set the Points. This scales the assignment to a particular value. 
 Set the Category. This is important whether or not you are using weighted 

categories. 

 

Click Next Assign to add another assignment. Click Done when finished. 

Understanding Max Score vs. Points or Balanced vs. Unbalanced Grades: 

TIP: Your default action is to set the Points value equal to the Max. Score, but consider 
the following. 

If you want all tests to weigh equally regardless of Max. Score then set the Points value 
equal for all tests. Consider this for any assignment that is repetitive and meets these 
criteria (quizzes). 

Communicate your grading practices on this issue! Example: “You will have four 
exams in this class. All will be weighted equally towards your Exam Category grade.” OR 
“Assignments with more points will count more towards your final grade in this category.” 
The first example is balanced grades where the Points are set the same. The latter is 
unbalanced where Max Score and Points are always kept the same. Both are sound 

Set the Due Date 
for the assignment. Navigate to previous 

assignments to make 
changes. 
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6.  Copying Class Settings and Assignments 

Now that you have entered Categories, Footnotes, and Assignments, it’s time for Easy 
Grade Pro to do some work for you. EGP allows you to copy information from one class to 
another or to set them up individually. 

To copy Class Settings or Assignments, go Tool > Copy and make your selection. The 
steps for copying information are the same for all selections: 

1. Set the Copy FROM and TO classes. You can copy information to more than one 
class. 

2. Specify which assignments, class data, options, seats, or students in the right panel. 
3. Double check your work and press Copy. 

 

 

  

 

 

 

 

1. Set Copy FROM 
and TO locations. 

Change the 
Information to Copy. 

3. Double Check and 
Press Copy. 

2. Specify which 
options/students/assign-
ments to copy. 



Instructional Technology  EGPv4 

  6 of 14 

B. Documentation 

1. Special Scores 

The Tool Palette is no longer a separate window in EGP 4. Instead, it is integrated into the 
toolbar at the top of the screen. The Mini-Summary remains visible where the Tool Palette 
was previously located. 

 

When entering grades, you can click on any letter grade or Special Score to assign the 
grade to a student.2 

2. Adding Notes to Scores 

By adding Notes to scores, you can 
document more information about a 
student’s performance.  

To add Notes, double-click on a students 
score. From this window, you can also 
change students and assignments at the 
bottom. 

Written notes can be just for the teacher, or 
visible to the student in a report. Your pre-
defined footnotes will be available in the lower half.  

To alter footnotes, go to Class Options under the Edit menu. 

Teacher Notes allow you to document your observations about a student’s performance 
without them being visible to the student or his/her parents. 

                                                 
2 Recall the keyboard shortcuts for Special Scores. To review these, return to Class Options under the 
Edit menu. 

Expand/Collapse 
Grade Shortcuts 

Change Format 
Here 
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C. Data-driven Instruction 

1. Color-coding Scores 

The most visible way to see trends regarding students not meeting standards in you class is 
to color-code your scores. To look at these options, go Edit > Class Options and click on 
the Color Tab. Here you can 

 Alter the colors of your gradebook for this class 
 Assign colors to grades based on specified criteria. 

 

In this example, we’ve assigned colors of increasing intensity to students not meeting 
standards (grades D and E). 

How to use this feature 

 If a lot of color shows up in one row, conference with the student, and plan on 
individualizing instruction for his or her needs. 

 If a lot of color shows up in one column, examine the instruction around that 
assignment and reteach, review, or reassess. 
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2. Sorting Student Information 

Another way to examine data trends within your gradebook is to sort assignments and 
students.  Examine how each of these hidden menus can help break down grades. 

 

 

 

 

 

 If students are looking over your 
shoulder (a no-no), consider 
showing ONLY that student. 

 Show only category-specific 
assignments 

 Look at your grades as percents or 
grades (letters) to more quickly track 
how students are meeting standards. 

Additionally, you can sort students by their 
course average. To do this, go View > Sort 
Students > by Average. Students will be 
ranked by course performance. 
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3. Filtering Student information 

Filters allow you to remove students not 
meeting a particular criterion. That is, if 
you want to show your top ten students, all 
students not meeting that criterion are 
temporarily hidden. To enable a filter, go 
View > Filters > and choose a filter. 

To Show All, choose the first option from 
the View Menu. 

 

4. Utilizing the Mini Summary 

The Mini Summary is a feature that you can 
look at constantly. Located in the upper left 
of your screen this window shows the 
overall distribution of grades in your class. 
You can change this view to look at 
individual assignments and more by 
clicking on the menu arrow in the upper-
right corner. 

If you see that there are unusual trends such 
as multiple failures on an assignment or class average, re-examine that assignment or 
student(s) and take appropriate action in your instruction to work with those topics or 
students. 

KEY: Look at your data, learn from it, and take action in your instruction! 

5. Data Analysis with Charts 

Charts put many data into a graphical 
representation. It does not interpret data for you; rather, it makes it easier for you to 
interpret trends for your students.  

To look at Charts, click on the Chart icon in the Tool Palette or go Chart > Summaries. 

Two different Charts are showcased below. Explore the different charts to see what 
information is useful in your instruction. 
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Class / Assignment Graphs  

The charting features of Easy Grade Pro have changed dramatically in EGP 4. All of the 
same charts are available, but they’ve upgraded the design to a menu-driven window, 
rather than tabs. 

 

In the Summaries window, select the Class or Assignments Grades from the Type menu. 
Also check that the appropriate Class is chosen. You should navigate through your 
assignments periodically to get a picture of student performance in your class. 

For each assignment, you can click on any of the bars in the bar graph to see a list of 
students achieving at that level. Students’ performance below the C-level should be of 
primary concern to you. 

Student Performance 

From the Summaries window, select the 
Students Grades Type. Select students of 
concern (from the assignment graph) and get 
a better picture of their performance over 
time. 

Assignment Categories are shown in 
different colors. You should be looking for 
the following things: 

 Students showing declining performance 
– what types of assignments are they 
struggling with? Is it just tests? Homework? 

 Students showing improving performance – what concepts or teaching strategies have 
been effective with this student? How could you apply these strategies with struggling 
students? 

KEY: Look at your data, learn from it, and take action in your instruction! 

Concern Area 

More Options 
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D. Reporting Options 

All reports are now available from a single window. The most popular reports are Student 
Progress (report card), score chart, class roster, and seating chart. Please explore the others to 
suit your individual needs.  To begin go to File > Print. 

1. Student Progress 

All teachers will use the Student Progress (report card) feature as it has many options 
for displaying student performance data. Elementary teachers will additionally use the 
Include Multiple Classes option. Carefully examine the options on reports window 
before pressing Print. 

 

Selecting the right group of students 

 Use All students in <term name>:<class name>to print a report for the entire 
class 

 Use All students in <term name>to print a report for all your classes 

 Use selected students in the list to print a report for one or more students from the 
current class. Click on the List Tab and select multiple students with the mouse. 
 
TIP: To select multiple students in a row, select the first student, and then hold 
down the shift key to select the last student. All students in between will be selected. 
 
TIP: If you want to select non-continuous students, hold down the Ctrl key 
(Command Key on Mac) and select individual students. 

Include Multiple 
Classes 

Add Teacher 
Name Here 

Print When Ready 
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Setting Report Options 

You now need to decide what will be included in your report.   

 You can add and introduction and a conclusion to the report by checking the 
Include Intro/Postscript Text.  This is where you could include your contact 
information, address to your SWIFT site, even a note to sign and return the bottom 
portion of the report to the teacher. Press the Edit button to control each. 

 Include Grade Summary Chart gives the overall grade as well as your category 
grades, completed work average, grade scale key, and the number of missing 
assignments.  

 If you want to include a detailed account of all the assignments that were assigned 
during the grading period, select Include Assignment Chart. Here you can the 
number of assignments. 
 
TIP: use the Assignments on or after… feature to include assignments from only 
the latest unit material and save valuable paper. 

 Add your Teacher Name under the General Options for All Reports option. 

2. Score Charts 

Score charts can help you analyze how your class is doing overall as well as on individual 
assignments.  From File > Print, go to the Chart Tab. 

 

Blank columns for 
paper gradesheets 

Sort or Randomize 
Students  

Control Font Size and 
Orientation for Paper 
Conservation 

Print When Ready 
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 E. Gradebook Management 

1. File Management 

File Format: You must know where your 
gradebook is saved. Save your gradebook 
in the following format: 

TeacherName_SchoolYr.egp  

Gradebook Backup: Your gradebook is 
automatically saved as you use it. You 
must, however, save a backup copy. You be 
prompted to save a copy of your gradebook 
upon closing Easy Grade Pro. Make sure 
that you save it in another location. EGP will remember where you saved your l 

You can also manually make a backup. To do this, go File > Save Copy…. Save OVER 
that file each time you quite Easy Grade Pro. 

Automatic Backup Option in EGP 4.0: 
This new version allows you to continue 
being prompted each time your close OR to 
automatically save a backup. To manage 
these options, go Edit > Gradebook 
Options and choose the General Tab.  

Under the Backup Options, you must 
specifiy a Default Backup Location if you 
are going to use the automatic feature. 

TIP: On new computers in the district, you 
must save either to the D:Data drive of your H:Home drive. All other locations will delete 
your file overnight. 

2. Adding Terms 

At the end of the grading term (semester or 
quarter), you can add a new term for your 
classes. To do this, go Tool > Term Tools 
> Start New Term.  You will be prompted 
with the following dialogue box: 

 

Press Yes. You will now find the new class 
in the Class Menu of the Toole Palette. 

D: Data Drive 

H: Home Drive 
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3. Security and Your Gradebook – VERY IMPORTANT 

With student privacy laws as they currently are, you should consider password-protecting 
your gradebook a requirement.  To do this, go Edit > Gradebook Options and select the 
General Tab. Under Security/Password Options, you can set your Full Access Password. 
Teacher’s Assistants should never enter grades. 

  

Advantages of setting a password to your gradebook: 

 Your gradebook cannot be opened by another person. 

 You can Lock your gradebook when not using it. Enter grades or take attendance, 
then Lock it. This feature prevents others from viewing your gradebook while you 
are taking care of classroom needs. At the same time, it’s quick to re-enter your 
gradebook to keep working. 

Ctrl + L (PC) 
Command + L (Mac) 


